Go Back   Club Bazooka > Bazooka Technical Forums > Amplified Tube Subwoofers

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 05-12-2013, 12:43 PM
John3416's Avatar
John3416 John3416 is offline
Just Gettin Started
 
Join Date: May 2013
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
John3416 is on a distinguished road
Help 0003 plug needed

I have a 10 inch bass tube I obtained from my neighbor at a garage sale and need plag for it. It is an older amp style tube with the white 14 plug connector. X-over and level turn knobs red led, 15 and 7.5 fuses. And the + and - connectors. Inside the number is a8d10c3020 on the static cage and a8d1005020 on the board / amplifier. Can anyone help with this plug.
Reply With Quote
  #2  
Old 05-12-2013, 12:54 PM
John3416's Avatar
John3416 John3416 is offline
Just Gettin Started
 
Join Date: May 2013
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
John3416 is on a distinguished road
Default Re: plug needed

Here are pictures of the tube
Attached Images
File Type: jpg 1368380902500.jpg (88.1 KB, 4 views)
File Type: jpg 1368380969481.jpg (86.7 KB, 4 views)
Reply With Quote
  #3  
Old 05-13-2013, 01:23 PM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,950
Thanks: 351
Thanked 771 Times in 690 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 781
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: plug needed

Quote:
Originally Posted by John3416 View Post
I have a 10 inch bass tube I obtained from my neighbor at a garage sale and need plag for it. It is an older amp style tube with the white 14 plug connector. X-over and level turn knobs red led, 15 and 7.5 fuses. And the + and - connectors. Inside the number is a8d10c3020 on the static cage and a8d1005020 on the board / amplifier. Can anyone help with this plug.
That appears to be a A80 Tube. Here is a link to the replacement harness.

http://store.bazooka.com/RSA-hp-AWK-...ubes-P298.aspx
__________________
power your system down
Reply With Quote
The Following User Says Thank You to heavyduty For This Useful Post:
John3416 (05-13-2013)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.