Go Back   Club Bazooka > Bazooka Technical Forums > Motorcycle Products

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 07-31-2012, 07:59 AM
Smitty_'s Avatar
Smitty_ Smitty_ is offline
Just Gettin Started
 
Join Date: Jul 2012
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
Smitty_ is on a distinguished road
Help 0003 Excited but Powerless

Yesterday I received an MC-HD-AMK for my '10 H-D Ultra Limited (w/CB) with 4 H-D Boom Audio upgrade speakers already installed...
I read the instructions (pretty weak) and watched all the youtube install videos (pretty good)... no problem I thought...piece of cake.
So off to the garage to amp up my ride in preparation for my upcoming ride out to Sturgis (yippee)...
Followed the instructions except I wanted to check out the performance before I started locking everything down.

Everything was plug compatible as advertised, but I have no power...???

I ran the supplied wires directly to the + battery, to a good (verified) ground...fuse checks out good...no power and no sound. the MC-HD-AMK green LED never illuminated when the radio was turned on.

Any ideas???
Reply With Quote
  #2  
Old 07-31-2012, 10:20 AM
Geneh's Avatar
Geneh Geneh is offline
Super Moderator
 
Join Date: Feb 2008
Posts: 507
Thanks: 342
Thanked 153 Times in 131 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 163
Geneh has a spectacular aura aboutGeneh has a spectacular aura about
Default Re: Excited but Powerless

First make sure all the connectors are pushed in all the way. (2 ea. 35 pin, 2 ea 23 pin, 1 ea 8 pin and 1 ea. 10 pin)

Check voltage at the amp, putting your meter probes on the positive and negative terminals. This way your are checking the power and ground wire also. Make sure you are getting 12 vdc. Pull the white 10 pin molex connector out of the amp. Check to make sure it has 12 vdc on the blue w/white wire.


If you have voltage at the terminals and all the connectors are pushed in all the way. Then there is a problem with the amp.
__________________
"Shoot For The Top...... The Bottom Is Already Full"

Q u o t e s:
To err is human, but to really foul things up requires a computer. Farmers' Almanac, 1978
Reply With Quote
The Following 2 Users Say Thank You to Geneh For This Useful Post:
heavyduty (07-31-2012), Smitty_ (08-02-2012)
  #3  
Old 08-02-2012, 05:07 PM
Smitty_'s Avatar
Smitty_ Smitty_ is offline
Just Gettin Started
 
Join Date: Jul 2012
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
Smitty_ is on a distinguished road
Thank You Re: Excited but Powerless

@GENEH...
You are the man! Thanks...

Using a test meter with an independent ground I was overlooking my ground wire (appearances are not everything)...
I checked it as you said and there you go... bad ground loop...

It's working great now...
it's loud to say the least...can't wait to get up on the highway tomorrow and check it out at speed (I am excited)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:39 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.