Go Back   Club Bazooka > Bazooka Technical Forums > Component Amplifiers

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2012, 04:45 PM
dpitts66's Avatar
dpitts66 dpitts66 is offline
Just Gettin Started
 
Join Date: Jan 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
dpitts66 is on a distinguished road
Default P500d sounds weak

I have a P500d with 1 cvr dvc running at 2ohms. It had lots of power when installed. Now the bass is weak and destorts early. The sub could handle all the power if it didn't distort. I tried it in my buddies car with simular setup and it sound better but his old el 300 sounds better and hits lows alot better. I have 4 guage wiring kit
Reply With Quote
  #2  
Old 01-27-2012, 07:01 PM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,940
Thanks: 350
Thanked 768 Times in 688 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 778
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: P500d sounds weak

Quote:
Originally Posted by dpitts66 View Post
I have a P500d with 1 cvr dvc running at 2ohms. It had lots of power when installed. Now the bass is weak and destorts early. The sub could handle all the power if it didn't distort. I tried it in my buddies car with simular setup and it sound better but his old el 300 sounds better and hits lows alot better. I have 4 guage wiring kit
For starters, 2 gauge wire is recommended for the P500D. Second, the amperage draw of the ELA1300 is half that of the P500D. If your vehicle's electrical system cannot adequately provide an additional 80 amperage draw on top of powering all of the other vehicle accessories, any amplifier will distort easily, this not being unique to the P500D.
__________________
power your system down
Reply With Quote
  #3  
Old 01-28-2012, 12:05 AM
dpitts66's Avatar
dpitts66 dpitts66 is offline
Just Gettin Started
 
Join Date: Jan 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
dpitts66 is on a distinguished road
Default Re: P500d sounds weak

So, do you think that a wiring kit will solve the problem or is my charging system is weak? It reads 13.8v on my meter. The bass does not sound good at low volumes either but the amp does not go into protection mode. I have a 12v 18hr sla battery that I could install close to the amp if that would solve the problem. By no means am I bashing the amp. I know that it is a good amp. Thanks for your help!
Reply With Quote
  #4  
Old 01-30-2012, 10:25 AM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,940
Thanks: 350
Thanked 768 Times in 688 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 778
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: P500d sounds weak

Quote:
Originally Posted by dpitts66 View Post
So, do you think that a wiring kit will solve the problem or is my charging system is weak? It reads 13.8v on my meter. The bass does not sound good at low volumes either but the amp does not go into protection mode. I have a 12v 18hr sla battery that I could install close to the amp if that would solve the problem. By no means am I bashing the amp. I know that it is a good amp. Thanks for your help!
The proper gauge wire size will always help, however, if your charging system is not up to par, you could have the largest cable, most expensive capacitors and slave batteries installed and still have the same problem.

To get an ideal picture of what your charging system looks like you need to measure the voltage with the vehicle under normal conditions. This means with the normal accessories on, air conditioning, lights, stereo, etc. After you get a baseline measurement then turn the volume up and compare both measurements. If your alternator cannot keep up with the demand no amount of capacitors or slave batteries will solve the problem, only add to it. Remember, a capacitor only stores energy, and while a battery does add available amperage to the system, your alternator still has to work on keeping the additional battery charged, as well as the main battery.
__________________
power your system down
Reply With Quote
The Following User Says Thank You to heavyduty For This Useful Post:
Geneh (01-30-2012)
  #5  
Old 01-31-2012, 10:09 AM
dpitts66's Avatar
dpitts66 dpitts66 is offline
Just Gettin Started
 
Join Date: Jan 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
dpitts66 is on a distinguished road
Default Re: P500d sounds weak

I have tested the charging system in this fashion and it stays at 13.8v. My question would be why would it change after playing fine for a few months. I have checked all connections and they are fine. The amp has never went into protection mode. I am thinking about buying another amp to see if there is a problem with it. My buddy is talking much trash because his old el-300.1 hits alot harder and its a piece of crap with no bottom plate and wood screws holding the wires in place. It sounds incredible!!! LOL
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.