Go Back   Club Bazooka > General Discussion > Customer Service

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 12-11-2008, 08:19 PM
rayp4993's Avatar
rayp4993 rayp4993 is offline
Just Gettin Started
 
Join Date: Dec 2008
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
rayp4993 is on a distinguished road
Help 0003 I'm missing the two set screws for my amp

I am missing the two set screws for the speaker input ports on my bazooka ela 500.1 mono amp. Any info on where i can obtain these or anything would be great. Also my amp randomly hits real hard once then continues regular bass . If anyone knows whats going on with that, like i said help would be much apreciated.
Reply With Quote
  #2  
Old 12-11-2008, 08:56 PM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,868
Thanks: 333
Thanked 736 Times in 660 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 746
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: I'm missing the two set screws for my amp

Quote:
Originally Posted by rayp4993 View Post
I am missing the two set screws for the speaker input ports on my bazooka ela 500.1 mono amp. Any info on where i can obtain these or anything would be great. Also my amp randomly hits real hard once then continues regular bass . If anyone knows whats going on with that, like i said help would be much apreciated.
Welcome to the Bazooka Forum rayp. You can call Bazooka tomorrow (1-800-THE-TUBE) and ask to speak to the Tech. Department. They may have these set screws on hand or may be able to tell you the size of the set screw, allowing you to go to a hardware store and purchase replacements. As far as your next question, since your missing your set screws now, how are your speaker cables attached to the amp?
__________________
power your system down
Reply With Quote
  #3  
Old 12-12-2008, 04:06 PM
rayp4993's Avatar
rayp4993 rayp4993 is offline
Just Gettin Started
 
Join Date: Dec 2008
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
rayp4993 is on a distinguished road
Thank You Re: I'm missing the two set screws for my amp

well i got two set screws that work and it might have had something to do with the fact that the wires were just stuck in the slot. also i am missing the gain knob so i need to stick pliers in the hole to adjust it. I don't know if that plays a factor in the "random hard hit", my friend said it probably does..
Reply With Quote
  #4  
Old 12-12-2008, 04:11 PM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,868
Thanks: 333
Thanked 736 Times in 660 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 746
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: I'm missing the two set screws for my amp

Quote:
Originally Posted by rayp4993 View Post
well i got two set screws that work and it might have had something to do with the fact that the wires were just stuck in the slot. also i am missing the gain knob so i need to stick pliers in the hole to adjust it. I don't know if that plays a factor in the "random hard hit", my friend said it probably does..
I'd say that it is the reason why you are experiencing the randomness with the bass. You are in effect creating a situation where the wires do not make contact with the terminals, or are either causing a extremely high resistance due to an improperly connected terminal, therefore the sudden increase and decrease. And I would also caution about your gain settings, as if you are trying to compensate for the lack of bass from the inadequate connections, you are likely to send the amp into protection mode or worst case scenerio, a meltdown.
__________________
power your system down
Reply With Quote
  #5  
Old 12-12-2008, 04:14 PM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,868
Thanks: 333
Thanked 736 Times in 660 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 746
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: I'm missing the two set screws for my amp

Quote:
Originally Posted by rayp4993 View Post
well i got two set screws that work and it might have had something to do with the fact that the wires were just stuck in the slot. also i am missing the gain knob so i need to stick pliers in the hole to adjust it. I don't know if that plays a factor in the "random hard hit", my friend said it probably does..
Here is a link to the owner's manual in case you do not have one.
http://www.bazooka.com/pdf/current/E...DF%2012904.pdf
__________________
power your system down
Reply With Quote
  #6  
Old 12-12-2008, 04:26 PM
rayp4993's Avatar
rayp4993 rayp4993 is offline
Just Gettin Started
 
Join Date: Dec 2008
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
rayp4993 is on a distinguished road
Thank You Re: I'm missing the two set screws for my amp

Ok thank you.
Reply With Quote
  #7  
Old 12-12-2008, 04:27 PM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,868
Thanks: 333
Thanked 736 Times in 660 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 746
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: I'm missing the two set screws for my amp

Quote:
Originally Posted by rayp4993 View Post
Ok thank you.
No problem rayp. That's what the Bazooka Forum is for, helping people out.
__________________
power your system down
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:37 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.