Go Back   Club Bazooka > Bazooka Technical Forums > Amplified Tube Subwoofers

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 09-19-2012, 08:23 PM
Louis6507's Avatar
Louis6507 Louis6507 is offline
Just Gettin Started
 
Join Date: Sep 2012
Location: Central Florida
Posts: 15
Thanks: 4
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 11
Louis6507 is on a distinguished road
Help 0003 Received and Installed my BTA10250D Today....

The install went super smooth. These things really are so easy to install. The hardest part was running the power wire on my '07 Kia Spectra.

Apparently my car has a double insulated firewall and no grommets or openings through it. My mechanic/friend, who was giving me advice on things, told me not to go through a firewall like mine, because it obviously deals with a lot of heat in that area.

Well, with his help, we got around it just fine. (If anyone else has a problem with this, I'll be glad to give advice and explain how we did it.)

Anyway, here's my question:

I purchased my BTA10250D through one of the retailers you link to on it's product page (not sure if I should mention names or not). The packaging was fine, everything was included that should have been, and after installation, everything worked fine. However, are these tubes shipped with any kind of protective coating "designed" to flake off?

I mean, the entire outer "paint job" of my tube is a disintegrating, flaky mess of black "paint." It's horrible. It got all over me, my shirt, and my trunk, since I'm not sure if I should rub this totally off of my tube or not. Should I?

This doesn't affect the sound quality of my tube at all. But, does this mean my tube is going to age early or damage prematurely in the future?

If so, what should I even do about this? Am I going to have to send my tube back, and wait for a replacement that might have the exact same issue? After all, the box and bag it came shipped in, were totally sealed. How can anyone know this had this problem without opening the package?

If you need pictures of this mess, I'll gladly upload some. And, if it matters, I placed my order on 09/14 and just received it via FedEx today, 09/15.
__________________
Good from far is far from good.
"After I'm dead I'd rather have people ask why I have no monument than why I have one."
Do good instead of evil and try to live at peace. (Psalm 34:14)
Reply With Quote
  #2  
Old 09-19-2012, 08:27 PM
Louis6507's Avatar
Louis6507 Louis6507 is offline
Just Gettin Started
 
Join Date: Sep 2012
Location: Central Florida
Posts: 15
Thanks: 4
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 11
Louis6507 is on a distinguished road
Default Re: Received and Installed my BTA10250D Today....

Quote:
Originally Posted by Louis6507 View Post
...and just received it via FedEx today, 09/15.
I meant to say, "...and just received it via FedEx today, 09/19.

Sorry....
__________________
Good from far is far from good.
"After I'm dead I'd rather have people ask why I have no monument than why I have one."
Do good instead of evil and try to live at peace. (Psalm 34:14)
Reply With Quote
  #3  
Old 09-20-2012, 07:31 AM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,950
Thanks: 351
Thanked 771 Times in 690 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 781
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: Received and Installed my BTA10250D Today....

Quote:
Originally Posted by Louis6507 View Post
The install went super smooth. These things really are so easy to install. The hardest part was running the power wire on my '07 Kia Spectra.

Apparently my car has a double insulated firewall and no grommets or openings through it. My mechanic/friend, who was giving me advice on things, told me not to go through a firewall like mine, because it obviously deals with a lot of heat in that area.

Well, with his help, we got around it just fine. (If anyone else has a problem with this, I'll be glad to give advice and explain how we did it.)

Anyway, here's my question:

I purchased my BTA10250D through one of the retailers you link to on it's product page (not sure if I should mention names or not). The packaging was fine, everything was included that should have been, and after installation, everything worked fine. However, are these tubes shipped with any kind of protective coating "designed" to flake off?

I mean, the entire outer "paint job" of my tube is a disintegrating, flaky mess of black "paint." It's horrible. It got all over me, my shirt, and my trunk, since I'm not sure if I should rub this totally off of my tube or not. Should I?

This doesn't affect the sound quality of my tube at all. But, does this mean my tube is going to age early or damage prematurely in the future?

If so, what should I even do about this? Am I going to have to send my tube back, and wait for a replacement that might have the exact same issue? After all, the box and bag it came shipped in, were totally sealed. How can anyone know this had this problem without opening the package?

If you need pictures of this mess, I'll gladly upload some. And, if it matters, I placed my order on 09/14 and just received it via FedEx today, 09/15.
The finish of the Tube should not be rubbing off, period. As far as the Tube aging because of this, that will not happen, specifically because of the materials the Tubes are constructed off.

You have two options, return the Tube to the original retailer or call Customer Service at 1-800-THE-TUBE. Ideally, your first call should be to Customer Service that way the serial number of the Tube can be traced back to what, if any problems there may have been when the Tube was manufactured, and if there was not any problems, at least this incident can be recorded.
__________________
power your system down
Reply With Quote
The Following 2 Users Say Thank You to heavyduty For This Useful Post:
Geneh (09-20-2012), Louis6507 (09-20-2012)
  #4  
Old 09-20-2012, 01:34 PM
Louis6507's Avatar
Louis6507 Louis6507 is offline
Just Gettin Started
 
Join Date: Sep 2012
Location: Central Florida
Posts: 15
Thanks: 4
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 11
Louis6507 is on a distinguished road
Default Re: Received and Installed my BTA10250D Today....

Quote:
Originally Posted by heavyduty View Post
The finish of the Tube should not be rubbing off, period. As far as the Tube aging because of this, that will not happen, specifically because of the materials the Tubes are constructed off.

You have two options, return the Tube to the original retailer or call Customer Service at 1-800-THE-TUBE. Ideally, your first call should be to Customer Service that way the serial number of the Tube can be traced back to what, if any problems there may have been when the Tube was manufactured, and if there was not any problems, at least this incident can be recorded.

Well, as long as the tube will not fall apart, I'll just keep it. The return policy of the place I got it from is to not pay for return postage and they will only resend the replacement after recieving the tube I send in. Which translates into going another 2-3 weeks without the tube I paid $240 for already a week ago.

I didn't buy through Amazon, because I read on these forums about unauthorized resellers. But, Amazon's return policy is unbeatable. I will be getting my slave unit (BT1014) trough Amazon. The extra $15-$25 is worth it, with the 3 day delivery and free delivery for a return. The problem really appears to be either this tube is quite old or was exposed to tremendous heat, since moisture would have appeared on the box.

I don't care about looks, I care about results, and hands down, this BTA10250D is F*&#ING AMAZING!!!! ^_^

I have the High Pass filter on my head unit blocking everything above 125hz from all of my speakers except the Bazooka and it handles everything perfect from my Christian Rock to Country, to Pop, to K-Pop and J-Pop. And, when I play my heavier bass stuff from Eminem to Nicki Minaj, it sounds great! Zero distortion even with the gain turned up 100% at my head unit and on the tube. Even at high volume.

I'll be getting the slave unit, just to go over-the top.

If anyone owns a Kia sedan or something similar, with an aftermarket head unit and factory speakers, the BTA10250D will be perfect! ^_^

I do keep one seat folded down. But, I have always done that.
__________________
Good from far is far from good.
"After I'm dead I'd rather have people ask why I have no monument than why I have one."
Do good instead of evil and try to live at peace. (Psalm 34:14)
Reply With Quote
The Following User Says Thank You to Louis6507 For This Useful Post:
heavyduty (09-20-2012)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:48 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.