Go Back   Club Bazooka > General Discussion > Customer Service

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 12-07-2008, 07:51 PM
matt_brouwer's Avatar
matt_brouwer matt_brouwer is offline
Just Gettin Started
 
Join Date: Dec 2008
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
matt_brouwer is on a distinguished road
Default Help

I purchased a EL10190PP subwoofer, box, amplifier kit from Circuit city yesterday (12/06/2008). I installed it and the amplifier does not work. I know it does not work because my nephew purchased the same kit and we put his in my truck to see if there was something wrong with my wiring and it worked great. I put mine back in and the amplifier does not work - since the speakers are wired from the factory, I thought maybe the wires were not hooked up to the subs in the box - they are. All fuses are good, tested all wires with electrical tester - everything is good. Green power light is on amp - protection light is off. No sound. Circuit city does not have any more of these units in stock, how can I get the amp replaced or repaired under warranty ?
Reply With Quote
  #2  
Old 12-07-2008, 08:19 PM
heavyduty's Avatar
heavyduty heavyduty is offline
Super Moderator
 
Join Date: Jan 2008
Posts: 2,868
Thanks: 333
Thanked 736 Times in 660 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 746
heavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to beholdheavyduty is a splendid one to behold
Default Re: Help

Quote:
Originally Posted by matt_brouwer View Post
I purchased a EL10190PP subwoofer, box, amplifier kit from Circuit city yesterday (12/06/2008). I installed it and the amplifier does not work. I know it does not work because my nephew purchased the same kit and we put his in my truck to see if there was something wrong with my wiring and it worked great. I put mine back in and the amplifier does not work - since the speakers are wired from the factory, I thought maybe the wires were not hooked up to the subs in the box - they are. All fuses are good, tested all wires with electrical tester - everything is good. Green power light is on amp - protection light is off. No sound. Circuit city does not have any more of these units in stock, how can I get the amp replaced or repaired under warranty ?
Welcome to the Bazooka Forum Matt. I am sorry to hear about the problems you are having with your amplifier. However, rest assured that you are dealing with a company that has the best customer service in the industry. On Monday, call Bazooka (1-800-THE-TUBE) and ask to speak to CJ, the customer service manager. Describe the problem to her and your amplifer will be taken care of, either repaired or replaced under warranty.
__________________
power your system down
Reply With Quote
The Following User Says Thank You to heavyduty For This Useful Post:
matt_brouwer (12-07-2008)
  #3  
Old 12-08-2008, 07:53 AM
CJ's Avatar
CJ CJ is offline
Junior Member
 
Join Date: Jan 2008
Location: Baton Rouge, LA.
Posts: 66
Thanks: 0
Thanked 71 Times in 52 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 81
CJ will become famous soon enough
Default Re: Help

I'm sorry the unit does not work for you. Please contact our customer service department at (800) 843-8823 between 8:30 - 5:00 central time. We will issue you a return authorization to send the amp in. You will need the serial number for your unit, and will need to be able to send a copy of your purchase receipt in your box. You only need to return the amplifier out of the party pack. This will save on the shipping costs for you. Again, I'm sorry about the problems you are having, but we should be able to get you taken care of.
CJ
Reply With Quote
The Following 2 Users Say Thank You to CJ For This Useful Post:
heavyduty (12-08-2008), Kingfish (12-08-2008)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:55 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.