Go Back   Club Bazooka > General Discussion > Customer Service


Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-25-2008, 06:36 PM
BigNokex's Avatar
BigNokex BigNokex is offline
Just Gettin Started
Join Date: May 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 10
BigNokex is on a distinguished road
Default Problem

I have 2 of these subwoofers

I have not had any luck with them, the first one i had to replace a harness for 15$ which is ehh, not a big deal. Now they both just decide when they would like to shut off while im listening to music.
I know for a FACT the power is fine, because my 800 watt amp for my speakers is not turning off nor is my deck and nothing dims.

Are there any suggestions i mean if not this was a complete waste of my money and i havent been satisfied.

My dad uses a BTA8100 and his is Perfect but my 2 woofers are crap for some reason there almost 6 months old id say
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 11:23 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.