Thread: Help!
View Single Post
  #2  
Old 06-15-2008, 10:33 PM
rainmanspl's Avatar
rainmanspl rainmanspl is offline
BAZOOKA Man
 
Join Date: Jan 2008
Location: Alto, GA, USA.
Posts: 1,634
Thanks: 184
Thanked 175 Times in 161 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Reputation: 178
rainmanspl has a spectacular aura aboutrainmanspl has a spectacular aura about
Default Re: Help!

Quote:
Originally Posted by tim1087 View Post
Ok, I bought the Bazooka Party pack, came with the 2 10" subs, amp, and box. I bought the wiring kit, everything was ready to go.

Wired the power wire from my battery all the way back to my amp. The power wire has a fuse bridging it, with a 40 amp fuse in it.

Wired the rca cables and Remote cable from the back of my head unit,to my amp.

Wired the ground grom my seatbelt bolt..back to the amp.

Plugged the 25 amp fuse that came with the kit into the amp..turned the key..and boom, the fuse blew...

Hmm...checked all the wiring, put a new fuse in..boom..blew again.

I even tried moving the ground location..the wire is inbetween 2 metal washers..boom, blown fuse.

What's the problem? Only the fuse in the amp is blowing, not the fuse in the power cable. The power light on the amp goes on..then fades out..and the fuse pops.

What can this be? Any help? Thank you.



Check the connections at the amp. Be sure there are no stray strands of wire. Use a DMM and check the resistance at the amps speaker connections. It is possible a speaker wire may have come loose in shipping and shorting the outputs. And again be sure you have proper polarity on your power inputs.
__________________
"Acoustics is the study of sound; a branch of physics dealing with sound. The law of physics is constantly challenge. Therefore in relation to acoustics; You must study constantly, for you will be constantly challenged." ...... Rainmanspl
Reply With Quote