Go Back   Club Bazooka > Search Forums

Notices

Showing results 1 to 5 of 5
Search took 0.01 seconds.
Search: Posts Made By: awc5004
Forum: Customer Service 08-07-2012, 08:51 AM
Replies: 7
Views: 1,673
Posted By awc5004
Re: BTA8100 BT recently developed problem

Also, I dont know why, but my last 2 posts, where I included pictures, are not showing up.

Anyways, after my tube completely stopped working, I unscrewed the amp to find the 2 boards not...
Forum: Customer Service 08-06-2012, 04:19 PM
Replies: 7
Views: 1,673
Posted By awc5004
Forum: Customer Service 08-06-2012, 04:15 PM
Replies: 7
Views: 1,673
Posted By awc5004
Re: BTA8100 BT recently developed problem

Well i got an RMA number, but I forgot to ask about a return address!

Its after hours now, so does anyone know the return address?

Thanks
Forum: Customer Service 08-05-2012, 09:01 AM
Replies: 7
Views: 1,673
Posted By awc5004
Re: BTA8100 BT recently developed problem

Hoping to send this in since it is still under warrenty.

Is there a customer service number?
Forum: Customer Service 07-29-2012, 10:20 AM
Replies: 7
Views: 1,673
Posted By awc5004
Help 0003 BTA8100 BT recently developed problem

I have owned my 8" tube since October 2011. Up until a few days ago, I couldn't be happier with the purchase.

Recently my tube has started producing sounds of what I can only describe as random...
Showing results 1 to 5 of 5

 
Forum Jump

All times are GMT -5. The time now is 09:40 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.