Go Back   Club Bazooka > Search Forums

Notices

Showing results 1 to 25 of 500
Search took 0.05 seconds.
Search: Posts Made By: heavyduty
Forum: Amplified Tube Subwoofers 06-29-2015, 02:37 PM
Replies: 1
Views: 22
Posted By heavyduty
Re: BTA6100 Help....again!

The thump-zzz, is this only when music is playing, or do you notice it when the car is at idle or moving? Does the sound stay constant, or does it vary in speed?

First thoughts, check your...
Forum: Amplified Tube Subwoofers 06-18-2015, 10:10 AM
Replies: 1
Views: 55
Posted By heavyduty
Re: 10in Amplified 250w tube

You will have to replace the current subwoofer with a 4 ohm DVC model, to have a 2 ohm mono load.
Forum: Amplified Tube Subwoofers 05-28-2015, 10:51 AM
Replies: 3
Views: 112
Posted By heavyduty
Re: BTA10100 new install

Yes, it is normal. Have you ever noticed how slow the interior lights of your car turn off after you exit? But when they are off, they are off.
Forum: Amplified Tube Subwoofers 05-26-2015, 10:18 AM
Replies: 3
Views: 112
Posted By heavyduty
Re: BTA10100 new install

Move the red wire of the Tube to the constant +12v power, and the blue/white wire of the Tube to the switched +12v power. This should see the green light turn off.
Forum: Passive Tube Subwoofers 05-22-2015, 02:41 PM
Replies: 1
Views: 103
Posted By heavyduty
Re: what is optimal low pass frequency

Optimal is 90hz, and adjust down from there. However, since you do not have that available, start at 100hz. I say optimal, as 90Hz is the maximum frequency before bass begins to become directional....
Forum: Amplified Tube Subwoofers 05-12-2015, 09:01 AM
Replies: 6
Views: 178
Posted By heavyduty
Re: New tube BTA6250D shows no power

Contact customer Service and they will issue you a RA#
Forum: Amplified Tube Subwoofers 05-12-2015, 08:07 AM
Replies: 6
Views: 178
Posted By heavyduty
Re: New tube BTA6250D shows no power

What pins are you using to verify power and remote on the Tube's 14 pin connector?
Forum: Amplified Tube Subwoofers 05-11-2015, 11:15 AM
Replies: 6
Views: 178
Posted By heavyduty
Re: New tube BTA6250D shows no power

What inputs are you using for your signal source?
Forum: Amplified Tube Subwoofers 05-06-2015, 09:06 PM
Replies: 5
Views: 260
Posted By heavyduty
Re: Powered Subwoofer Wiring

What owner's manual do you have? Yes, connect both sets of the Tube's high-level inputs to the signal source.
Forum: Amplified Tube Subwoofers 05-04-2015, 09:26 PM
Replies: 5
Views: 260
Posted By heavyduty
Re: Powered Subwoofer Wiring

Thoughts? Absolutely, and it is an easy fix. If you are connected to a speaker, like a tweeter, that has no bass information present, what is the Tube supposed to reproduce?

The owner's manual...
Forum: Amplified Tube Subwoofers 05-04-2015, 12:46 PM
Replies: 5
Views: 260
Posted By heavyduty
Re: Powered Subwoofer Wiring

Nope. You are not doing anything by connecting to the speakers, other than producing a signal source. You are not powering the Tube, again, only creating a signal source from this location. Check...
Forum: Marine Audio 04-29-2015, 02:56 PM
Replies: 1
Views: 194
Posted By heavyduty
Re: MARINE MA475D (Speaker connecting terminals)

You are seriously over thinking this. Feel free to use any type of stranded copper wire. These terminals are usually made out of brass.
Forum: Component Amplifiers 04-29-2015, 02:52 PM
Replies: 1
Views: 181
Posted By heavyduty
Re: bazooka 200 watt csa 50.2

300 watts is the max power rating, and it really doesn't mean anything as far as output. Wire each speaker in parallel, and connect to each channel. A 2 ohm stereo load is equal to the bridged...
Forum: General Chat 04-14-2015, 08:31 AM
Replies: 6
Views: 401
Posted By heavyduty
Re: mounting tube

My first suggestion is to run like hell. At the very minimum, you are looking at potential port noise, from the screws in the port area. However, that is one piss poor way of mounting anything. ...
Forum: Amplified Tube Subwoofers 04-14-2015, 08:26 AM
Replies: 3
Views: 214
Posted By heavyduty
Forum: Amplified Tube Subwoofers 04-13-2015, 07:45 PM
Replies: 3
Views: 214
Posted By heavyduty
Re: Bta250d turns on once, then needs unplugged before next use

Yes, and it is an easy fix. You are running into an impedance problem using the factory sub for a signal input. Install an LOC and the problem will disappear. Find one that has a trigger output...
Forum: Amplified Tube Subwoofers 04-06-2015, 01:38 PM
Replies: 3
Views: 584
Posted By heavyduty
Re: Mounting the tube my way!

Vertical performance will be fine. In fact, no different than a proper corner loading, horizontal position.
Forum: Amplified Tube Subwoofers 04-06-2015, 01:37 PM
Replies: 3
Views: 584
Posted By heavyduty
Re: Mounting the tube my way!

Mounting the Tube vertically, mimics the correct way to install. Instead of firing towards the taillights or the side of the vehicle, you are firing it into the floor which is like one big corner. ...
Forum: General Chat 03-26-2015, 01:04 PM
Replies: 6
Views: 401
Posted By heavyduty
Re: mounting tube

Take a look at how you have them fastened. Many times, the straps are unable to securely fasten the Tube, as the way the strap is positioned in the buckle, will not allow the strap to tighten, or...
Forum: Customer Service 03-24-2015, 11:41 AM
Replies: 1
Views: 154
Posted By heavyduty
Re: BT Series 12"

I don't think the problem is with the Tube. You should check out the amplifier, as well as the power and ground wires.
Forum: General Chat 03-23-2015, 09:13 AM
Replies: 6
Views: 401
Posted By heavyduty
Re: mounting tube

I find using the mounting bases and straps, seem to work really well.
Forum: Amplified Tube Subwoofers 03-18-2015, 10:23 AM
Replies: 189
Views: 63,671
Posted By heavyduty
Re: FAST-9999 Installaton Instructions

It is rare, but it does happen. Enjoy those low's.
Forum: Passive Tube Subwoofers 03-18-2015, 08:43 AM
Replies: 2
Views: 256
Posted By heavyduty
Re: Help with Bazooka NOS8

How about this, for an answer? Is it an ideal way? No, absolutely not.

Let's begin with your signal source. By powering the NOS8, off of the right rear speaker, you have changed the impedance...
Forum: Amplified Tube Subwoofers 03-18-2015, 08:37 AM
Replies: 6
Views: 272
Posted By heavyduty
Re: Trouble with grounding (maybe)

You are still dealing with an installation issue. You have a less than adequate ground connection, and you obviously have a issue with either the location, or installation, of your in-line fuse...
Forum: Amplified Tube Subwoofers 03-13-2015, 01:39 PM
Replies: 189
Views: 63,671
Posted By heavyduty
Re: FAST-9999 Installaton Instructions

Have you tried disconnecting the left speaker wires from the FAST-9999, and connecting the right speaker wires of the FAST-9999 only, to the left speaker?
Showing results 1 to 25 of 500

 
Forum Jump

All times are GMT -5. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.