Go Back   Club Bazooka > Search Forums

Notices

Showing results 1 to 8 of 8
Search took 0 seconds.
Search: Posts Made By: signguy62
Forum: Amplified Tube Subwoofers 07-01-2015, 10:03 PM
Replies: 3
Views: 126
Posted By signguy62
Re: BTA6100 Help....again!

^ read that as....(thanks to your install advise)
Forum: Amplified Tube Subwoofers 07-01-2015, 10:00 PM
Replies: 3
Views: 126
Posted By signguy62
Help 0003 Re: BTA6100 Help....again!

Just when the music is playing. The thump in the bass sounds distorted. The thing sounded great in her Jeep (thanks to your install ad use) but the bass just sounds so distorted in this hatchback....
Forum: Amplified Tube Subwoofers 06-28-2015, 05:26 PM
Replies: 3
Views: 126
Posted By signguy62
BTA6100 Help....again!

I'm back! Had this hooked up in my kids Jeep. Now I've moved it to a car w/hatch back. Install went great and it's working fine....I guess. It's got a lot of distortion. Rather than thump cleanly...
Forum: Amplified Tube Subwoofers 01-20-2015, 05:32 PM
Replies: 3
Views: 188
Posted By signguy62
Re: Help!

Thanks HeavyDuty! I'll check out the connections again. I know its working but I just dont want to damage/fry anything. :eek:
Forum: Amplified Tube Subwoofers 01-19-2015, 05:43 PM
Replies: 3
Views: 188
Posted By signguy62
Re: Help!

It's a BTA6100. I need to know if I wired something wrong since it seems to be working fine but the green light isn't on. :(
Forum: Amplified Tube Subwoofers 01-18-2015, 09:00 PM
Replies: 3
Views: 188
Posted By signguy62
Help!

Just hooked up a 100A in my daughters Jeep TJ. Fused wire to + battery, second wire to accessory/antenna at head unit, RCA cables/low input and grounded to body. Everything seems to be working fine...
Forum: Amplified Tube Subwoofers 06-13-2014, 05:03 PM
Replies: 3
Views: 773
Posted By signguy62
BTA850FH install ??

Okay I read through the forums and as far as I can tell I'm hooked up right. The tube works, powers up and thumps! But I'm having some issues. I dont have the FAST system just the harness that plugs...
Forum: Introductions 06-13-2014, 04:25 PM
Replies: 0
Views: 378
Posted By signguy62
Hello from NJ

New here, just got a BTA850FH and having some problems. I'll search the forum before I start asking questions that may have already been answered.
Showing results 1 to 8 of 8

 
Forum Jump

All times are GMT -5. The time now is 05:24 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.