Club Bazooka

Club Bazooka (http://www.bazooka.com/forums/index.php)
-   Hook me up! (http://www.bazooka.com/forums/forumdisplay.php?f=19)
-   -   sparks (http://www.bazooka.com/forums/showthread.php?t=5599)

grindking570 12-30-2008 04:20 PM

sparks
 
hey im new to the forums and new to the bazooka tube as well. but i got one for free pretty much and decided to hook it up. i hooked up the rcas then the power wire. when i got to the ground i found a screw. I touched the wire to the screw and spark shot out. idk how else to hook it up. i soudered the wires myself because it didnt come with the harness.

heavyduty 12-30-2008 04:28 PM

Re: sparks
 
Quote:

Originally Posted by grindking570 (Post 25933)
hey im new to the forums and new to the bazooka tube as well. but i got one for free pretty much and decided to hook it up. i hooked up the rcas then the power wire. when i got to the ground i found a screw. I touched the wire to the screw and spark shot out. idk how else to hook it up. i soudered the wires myself because it didnt come with the harness.

Welcome to the Bazooka Forum grindking. You can never go wrong with free. The spark from your ground is normal, as you are completing the circuit. However, it is always best to connect the ground before your power the Tube or any other component. Just remove the inline fuse, ground your terminal, put the fuse back in and you should be good to go. If you run into anymore problems or have any other questions, feel free to post back or use the PM. :)47


All times are GMT -5. The time now is 01:06 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
bazooka.com